
GEOG 2017EL 
 

Lab 6 February 8, 2010 
 Comparing Classification Methods and Class Breaks (15 points) 

Purpose: 
The purpose of this lab is to learn different classification methods for ranged-data. 
 
You will also learn how to add new data frames in ArcMap to allow you to create insets, 
extent maps or compare various classifications of the same mapped data. 
 

Part 1 Setting up Multiple Data Frames 
 
The last lab asked you to save your map document (mxd) file.  You will re-use this file to 
complete this lab. 
 

1. Open the file you saved in Lab 5. 
2. Make sure that you have the following layers (your names might vary) 

a. Ontario 
b. OntarioCD (mine is called Ontario_CD) 
c. OnCDdata (tabular data) 

 
3. The “Join” that you created in the last lab should still be active. 

a. Check this by Opening the Attribute table of your OntarioCD file. (Right-
click on layer name > Open Attribute Table) 

i. You should see the joined fields from the tabular data at the end 
(scroll to the far right end) of the attribute table 

b. You can also do this by checking the Properties of the OntarioCD file. 
(Right-click layer name > Properties or double-click on the layer name – 
this has to become second nature to you). 

i. Select the Joins & Relates tab. You should see OnCDdata in the 
Joins list.  This confirms that your joins are intact. 

 

Changing Field Names 
When you joined the OnCDdata tabular file to the OntarioCD shape file, some 
columns had Field_1, Field_2, etc. as headers.  These are the variables, or 
“Characteristics,” we imported from E-Stat.  Unfortunately, exporting to dbf 
causes this automatic cryptic naming of variables.  We need to change the 
field names (column headers). 

 
1. Right-click on the OntarioCD layer name 
2. Select Properties. 
3. In the Table Properties window, make sure the Fields tab is selected. 
4. Next to each field name is an Alias column.  You cannot change the field 

name but you can change its Alias.  You will have to scroll down towards 
the bottom because Joined fields are added to the end of a file’s field list. 
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Notice in the Field Name column that the table of origin always preceeds the 
actual field name Eg.  CDUID reads as Ontario_CD.CDIUD, while ShortGeo 
reads as OnCDdata.ShortGeo (remember the dbf table)  
5. Type in an appropriate alias for each field by simply clicking on the 

existing Alias name (by default, it’s the same as the field Name).   
Name  Alias 
Field_1  Pop2001 
Field_2  Pop2006 
Field_3  PopChg 
Field_4  LandArea 
 

 
 
 
6. Close the Table Properties window. 

Q1.  What table or shapefile does the GEOCODE variable come 
from (1 point) 

Adding New Data Frames 
 
A data frame is represented by stacked yellow sheets. The default name for a data 
frame is “Layers” (there’s a different default name when adding a new data frame).  
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Much like a layer, a data frame can be renamed, removed, copied, pasted, etc.  Also, 
there are many Properties associated with a data frame, the most important of which is 
Coordinate System/projection, which we will address in a later lab. 
 
You can have many Data Frames in your map document.  Each data frame will appear 
in your layout.  This may not be obvious right away since a data frame can be hidden by 
another data frame on top of it. 
 

Add multiple data frames to your map document 
1. Make sure you are in Data View (though technically this can also be done from 

the layout view)  
2. Adding a new data frame 

a. From the Main Menu >Insert >Data Frame 
b. This will add an empty data frame called New Data Frame. The data 

frame has NO layers, no data. 
You can add data to this date frame using the add data icon, but in our case 
we want to copy data from an existing data frame, in this case the “Layers” 
data frame. 
c. To do this, simply click on the Ontario layer name to highlight it, then drag 

it to the New Data Frame (just below the New Data Frame title) 
You can also copy and paste layers between data frames 
d. Right-click on OntarioCD layer in the Layers data frame > Copy 
e. Now Right-click on New Data Frame title>Paste Layer(s) 
 

3. Copying a data frame. 
If the data frame you want to copy has all the layers you want to duplicate, you can 

a. Right-click on the Layers data frame name>Copy 
b. Then from Main Menu Edit>Paste (or you can simply click the usual Paste 

icon) 
4. Copy the Layers data frame one more time.  You need a total of four data 

frames. 

 
 
Q2.  What is the name of the data frame you just created using 
this last technique (step 4 above)? (1 point) 
 
Q3. Are your Joins intact in all your copied OntarioCD layers?  (1 
point) 
 
Changing Data Frame Names 
This is getting confusing - too many data frames with the same or similar names.  We 
are going to use these data frames to compare Classification methods, so we’ll name 
each data frame after a particular technique.  To change a Data Frame’s name, simply  

1. Right-click on the name>Properties 
2. Make sure the General tab is selected and type in: Natural Breaks  

Note (you can bring up Data Frame Properties by simply double clicking on the data 
frame name – same as a layer) 
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You can also change a Data Frame name by clicking on it once, then wait a 
moment and click on it again (same as changing a file name). Change the rest of the 
data frames to the following: 

 Equal Interval  
 Quantile 
 Manual 

 

Active Data Frame 
Notice that of all the new data frames you created or copied, only one has its name in 
bold lettering.  This is to tell you which data frame is Active.  Anything you do with the 
Tools happens to layers on the Active Data Frame only.   

1. Zoom-in to southern Ontario in your currently active data frame.  
 

2. Now Activate another data frame.  To do this, Right–click on the data frame 
name which you want to activate, then click Activate on the context menu. 

 
Q4.  Is this newly activated data frame zoomed in to the same 
extent as the one you zoomed-in to southern Ontario?  (1point) 

 
3. Go back to the data frame that you zoomed in to southern Ontario and make 

sure you zoom back to the previous extend (or full Extent) so that the whole 
province is showing. 

 
Managing your data frames in Layout View 

1. Go to Layout View. 
It may not appear that all your data frames are in your layout because they are 
stacked.  The key to managing your data frames in the Layout View is your Select 
Elements Tool in the Tools menu. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

2. You need to change your page layout to Landscape (File>Page & Print set up...) 

 4



3. Select one data frame at a time with the Select Elements tool and move them to 
the four corners of your page.  A data frame is selected when it has a dashed line 
around it and blue (sometimes green depending on whether you’ve selected 
multiple elements) “handles” 

 

 
 

We are going to pre-size one of your data frames and make all the others the same 
size; to do this: 
4. Select one of your data frames in Layout View 
5. Right-Click>properties 
6. Select the Size and Position Tab 
7. In the Size box 
Type in 4 for Width 
Type in 4 for Height 
8. Leave As Percentage and Preserve Aspect Ratio unchecked. 

 
Now you have one data frame that will take up one quarter of your layout.  It’s easy 
now to make all data frames the same size. This step has to be done very carefully 
in exactly the right order. 
9. Select all the data frames one at a time holding down the shift key (or Ctrl will do 

too) but MAKE SURE THE DATA FRAME YOU SIZED TO 4”x4” IS THE LAST 
ONE SELECTED 

 
ALL the data frames should have dashed outlines with blue or green “handles” on 
them (the blue handles are reserved for the last one that you picked –WHICH 
SHOULD BE YOUR “PRE-SIZED” ONE. 

 
10. Right-click on any of the data frames (it doesn’t have to be the pre-sized one) in 

the Layout View for the context menu 
11. Select Distribute>Make Same Size.  All data frames in the layout view 

should now be the same size. 

 
12. Use your Select Elements tool to move the data frames as needed to fit all four 

onto the page. 
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Hint: There’s a way to better control how your layout is prepared using Guides to 
which you can snap objects. 
From the Main menu make sure the following are selected (they appear as 
depressed)  
 View > Rulers 
 View > Guides 

 
 

13. You can then add a guide (dashed line) to which you can snap objects. Because 
of the size of the data frames, I had to place my guides at the very top and 
bottom of the pages.  

 
Q5. How far from the left and right edges of the page are my 
data frames above (the ruler is in inches)? 

 

Part 2 Comparing Classification Methods (5 points) 
1. SAVE your work as Lab6_ClassType.mxd 
2. Go back to Data View 
3. For each of the four data frames, create a thematic map based on the 

classification scheme name of that layer using the Population Change (PopChg) 
variable 

4. E.g. for the Natural Breaks Data Frame double click on the OntarioCD layer 
>Symbology>Quantities>Graduated Color 

 6



Values:  PopChg (or Field_3) (check to see if that’s the right field name) 
Classification: Natural Breaks 

 
5. For the Quantile and Equal Interval data frames: 

a. Repeat the steps except at Classification, click the Classify button which 
takes you to the Classification window. 

b. In the Classification box, select the appropriate method (based on your 
data frame name) 

6. Make sure you still use only 5 classes for each method.  
7. Click Ok to close the classification window.  Do not change the color ramp – use 

the same one for all your maps here, 
8.  then Ok to apply the classification scheme to the data frame.   

 

9. Important For Manual Classification 
a. Repeat the same steps except at Method in the Classification window, 

select Manual, 
b. THEN RIGHT CLICK ON THE WORD “Manual” TO GET CONTEXT 

HELP and click on “What’s This?”.   This will teach you how to create 
manual breaks using the histogram in the window.  

If you make a mistake while doing a manual classification (or you want to 
start over) simply Cancel in the Classification window, and hit Classify button 
again in the Layer Properties >Symbology window. 

 

Adding legends 
1. Go to the layout view 
You need to add a legend for each data frame 
2. Activate a data frame (you can do this in the table of contents on the left, OR, just 

click on a data frame in your layout view with the Select elements tool, this will 
activate that data frame 

 
3. While in Layout View, go to the main menu and Insert a legend for each data 

frame.  In the Legend Wizard: 
a. Make sure only Ontario CD layer is in the Legend Items 

IMPORTANT 
b. IN LEGEND TITLE change the default title from “Legend” to the type of 

classification you are mapping, E.g. Natural Breaks, Quantile. 
 

4. You’ll need to activate each data frame one at a time and Insert>Legend one at a 
time.  Be careful where you place each legend, you want the right legend with the 
right data frame. 

 
YOU DO NOT NEED A NORTH ARROW OR SCALE BAR FOR 
THIS EXERCISE, but you still need a title with your name. 
5. SAVE Your work as Lab6_ClassType.mxd 

6. Export your layout as 
Lab6_Part2_ClassType_Fname_Lname.pdf and send to 
Holly and I 
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Part 3 Comparing number of classes (5 points) 
1. Open Lab6_ClassType.mxd 
2. Now save it immediately as 
3. Lab6_ClassNumber.mxd 
4. Make 4 Natural Breaks data frames to put on a single layout (in same way as 

above) This time you will compare 4 maps that use the same classification 
method (natural breaks) but each using a different number of class breaks.  Use 
4, 5, 6, and 7 class breaks. 

 
Again, YOU DO NOT NEED A NORTH ARROW OR SCALE BAR FOR THIS 
EXERCISE but you still need a title with your name. 

5. Don’t forget a legend (and legend title) for each data frame. 
6. Export your layout as Lab6_Part3_ClassNumber_Fname_Lname.pdf and send 

to Holly and I 
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