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LOGGING IN

     •  Connect to refworks 
         and then enter your personal Login 
         Name and Password.  (First-� me users 
         need to sign up for an individual 
         account following the screen prompts.)
    

http://librweb.laurentian.ca/login?url=http://refworks.scholarsportal.info/Refworks/newuser.asp
http://librweb.laurentian.ca/login?url=http://refworks.scholarsportal.info
Administrator
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Crea� ng Your RefWorks Database
RefWorks provides a number of op� ons for adding data to your database.

Impor� ng Data Directly Impor� ng Data from Saved Text Files

1.  Under the save or export func� on within the online 
service, select or click onto the save to RefWorks 
op� on.

2.  If you have your RefWorks account already open, the 
import will automa� cally begin.  If not, then you will 
be prompted to the RefWorks login page; a� er you 
login, the import will automa� cally begin.

3.  Select View Last Imported Folder to review the 
imported records.

Helpful Hint:  Every reference added to RefWorks 
(whether imported or entered manually) is given a print 
or electronic designa� on called Source Type.  This assists 
in ensuring you have all the relevant data REQUIRED in 
your bibliography.  A default Source Type may have been 
set by your local Administrator.  Users can set their own 
source type in the Tools menu, Customize area.

Conver� ng References from Other 
Bibliographic Management Products

RefWorks is compa� ble with a number of other 
bibliographic management products.  You can easily 
convert an exis� ng bibliographic management database 
such as EndNote into RefWorks.

For details related to impor� ng data from specifi c 
individual bibliographic management products, please 
refer to the online Help sec� on of RefWorks.
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References can be imported into RefWorks from a 
text fi le (.txt) created by saving references from a 
wide variety of online services and other bibliographic 
management programs.

1.  Retrieve the results you want to export from the 
online service or bibliographic manager, and save 
them to a text fi le.  If the database vendor lists 
several diff erent formats for saving the references, 
see the RefWorks Help fi le for further details on the 
appropriate selec� on.

2.  Access your RefWorks account and click References 
from the drop-down menu; then select Import.

3.  On the subsequent menu, access the drop-down 
menu next to Import Filter/Data Source and click the 
source of the data.

4.  Click on the Database drop-down menu and select 
the source database.

5.  Click on the Import References Into menu and 
designate the specifi c folder where you want to fi le 
the imported references.  If you do not choose a 
folder, the references will automa� cally go into a 
folder � tled Last Imported Folder.

6.  Enter fi le name into Import Data from the following 
Text File by browsing and selec� ng or manually typing 
in the fi le name.

7.  Click on Import at the bo� om of the screen.  When 
the import is complete, select View Last Imported 
Folder to review and modify the imported references.

Helpful Hint:  An up-to-date lis� ng of all the online 
services and databases that are supported by RefWorks 
can be found in the Import area by clicking on the List of 
Filters and Databases link. 
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Crea� ng Your RefWorks Database (Con� nued)

Manually Entering References Impor� ng from Online Catalogs or 
Databases

1.  Select References from the pull-down menu tool bar 
and then choose Add New Reference.

2.  Select a poten� al bibliographic output style (e.g., APA, 
Chicago, MLA) under View fi elds used by to enable 
the AccuCite feature.

3.  Designate the type of reference you are entering (e.g. 
journal, book or disserta� on) under Ref Type.  Field 
names marked with a green checkmark (�) indicate 
recommended informa� on needed to produce an 
accurate bibliography for the selected output style 
and reference type.  These fi elds are not required to 
save the actual reference in RefWorks.

4.  Enter informa� on in the boxes provided and click 
Save when fi nished.

Impor� ng from RSS (Really Simple Syndica� on) 

You can use RefWorks as a search interface for a number 
of online resources.       RefWorks provides access to 
a number of publicly available services such as NLM’s 
PubMed as well as many universi� es’ Online Catalogs.  
Addi� onally, ins� tu� onal subscribers may also provide 
access to subscrip� on-based online services (e.g., Ovid 
or ProQuest) through RefWorks.

1.  From the Search pull-down menu, select Online 
Catalog or Database.

2.  Under Online Database to Search, select a database 
from the drop down menu.

3.  Select the Max. Number of References to Download 
from the drop-down menu.

4.  Enter terms in either the Quick Search for: or in the 
Advanced Search for: box.

5.  Click on Search to begin your search.  A new window 
will open displaying your search results.

6.  Select the references you wish to import into your 
RefWorks account and click Import.
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RefWorks has integrated an RSS Feed Reader so you can 
easily add your favorite RSS Feeds from publishers and 
websites, view the informa� on and import data into your 
RefWorks database.  

1.  Locate the RSS Feed you wish to include.
2.  Right mouse click on the RSS Feed icon or link and 

select Copy Shortcut.
3.  From within RefWorks, select RSS Feed from the 

Search Menu.
4.  Paste the shortcut into the text bar and click the Add 

RSS Feed bu� on.
5.  Launch the RSS Feed by clicking on the name link.  

Your feed results will be displayed in a separate 
window for selec� on and impor� ng.
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Managing Your References
RefWorks provides you with a number of tools to organize, edit, and view references in your database.

Crea� ng Folders Globally Edi� ng References

1.  From the pull-down menu Folders, select Create New 
Folder.

2.  Enter a name in New Folder Name; click OK.

There is no limit on the number of folders you can create 
within your RefWorks account.

Helpful Hint:  The Last Imported Folder contains only 
references from your most recent data import that have 
not been fi led in other folders.  References from imports 
prior to your last import not assigned to specifi c folders 
remain available in your primary database but unfi led.

Pu�  ng References into Folders

1.  From the Search pull-down menu, do a search or look 
up to retrieve references already in your RefWorks 
database to put in a folder.

2.  Mark desired references from the search results page, 
then click the bu� on � tled Selected.  The selected 
references feature works on a page-by-page basis; 
this means that you must add the manually selected 
references to the desired folder before moving to the 
next page.  Alterna� vely, you can mark All in List or all 
on a Page.

3.  Select folder from the Put in Folder drop-down menu.
4.  References will automa� cally be added to the 

indicated folder.

Helpful Hint:  References can be assigned to more than 
one folder.

Sor� ng References

1.  From either the View or Folders pull-down menu, 
select a folder or group of references.

2.  Using the pull-down menu Sort by, located on the top 
right hand side of the page, choose to view references 
by various fi elds within your database.

1.  From the View pull-down menu, select All References 
or a folder of references.  You can also globally edit 
references from search results in RefWorks.

2.  Select the references you wish to edit.
3.  Click on Global Edit.
4.  Choose the specifi c fi eld to edit from the drop-down 

list.
5.  Type in the data you want to add to the fi eld in the 

Change Field to: box.
6.  Select the appropriate op� on for handling the fi eld 

- Append to Exis� ng Data; Overwrite Exis� ng Data 
(what you currently have in the fi eld will be gone); 
Leave Exis� ng Data Alone (if the fi eld contains 
data the edit feature will skip over that par� cular 
reference).

7.  Click OK.

Helpful Hint:  This feature is par� cularly useful for adding 
informa� on to records imported from online databases 
missing key fi elds necessary for a specifi c bibliographic 
output style.

Viewing Your References

When viewing All References, references in a Folder, or 
references within any search results, you can choose 
several diff erent ways to display them.  Note:  The 
display is customizable under the Tools pull-down menu, 
Customize.

1.  From the View pull-down menu, select All References 
or a folder of references.

2.  Go to the Switch To pull-down menu, select the 
output style for your selected references.  You may 
have up to 6 views in the pull-down menu.

Op� ons Available:
•  Standard View (includes Author, Title, Source Informa� on)
•  One Line/Cite View
•  Full View (all fi elds within record)
•  3 customizable output style views (i.e., APA, MLA, or Chicago)
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Crea� ng Your Paper and Bibliography
Write-N-Cite is a u� lity allowing Microso�  Word (and other word processor programs) users to cite references in a 

paper with the click of a bu� on.

Format a Bibliography From a List of 
References

1.  From the menu, select the Bibliography bu� on.
2.  Select an output format.
3.  Click on Format a Bibliography from a List of 

References.
4.  Select what fi le type to create.
5.  Select to format all of your references or only those 

from a specifi c folder.
6.  Click on Create Bibliography.
7.  A new window will open with your bibliography.
8.  Save your bibliography to your computer or disk.

Edi� ng or Crea� ng Your Output Style

Create a paper with in-text cita� ons using the RefWorks 
Write-N-Cite feature.

NOTE:  This u� lity is compa� ble with both Windows and 
Macintosh applica� ons.  In order to use this feature, you 
must fi rst download the Write-N-Cite u� lity from the 
Tools pull-down menu.

1.  Open a new blank document in Microso�  Word.
2.  Launch Write-N-Cite.
3.  Put the cursor in your Microso�  Word document 

where the reference should be inserted; click Cite 
next to the reference in the RefWorks screen.

4.  Save your Microso�  Word document when fi nished.

Write-N-Cite Bibliography

1.  Launch Write-N-Cite.
2.  Click on Bibliography.
3.  Select the output style.
4.  Click on Create Bibliography.
5.  A new window will open with the reforma� ed      

Microso�  Word document containing the 
bibliography.

6.  Save your Microso�  Word document.

RefWorks provides hundreds of output styles to choose 
from.  If one of these styles does not conform to your 
desired results, the Output Style Editor allows you 
to create custom output styles by either crea� ng a 
completely new style or modifying an exis� ng output 
style to suit your needs.

1.  Click on Bibliography.
2.  Click on Edit or New.

Access the Help menu for addi� onal assistance in 
crea� ng or edi� ng new bibliographic output styles.

Write-N-Cite Paper
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Crea� ng Your Paper and 
Bibliography  (Con� nued)

One Line/Cite View Paper

1.  From any reference view (all References, a folder or 
search results), click on the One Line/Cite View link.

2.  Click on the Cite link next to the appropriate 
reference.  A Cita� on Viewer window will appear 
containing the cita� on in an abbreviated format.

3.  To cite a second reference in the same loca� on just 
click on the Cite link by any other reference.  If you 
are using a Macintosh, you will need to click twice 
- the fi rst click will ac� vate the RefWorks program and 
the second will perform the Cite func� on.

4.  Once you have all of the references you need for a 
par� cular in-text cita� on, click on the Select Cita� on 
bu� on.

5.  Perform a copy command or simply drag and drop the 
cita� on into your word processor document.

6.  Go to your word processor, click on the document 
where you want the cita� on inserted and Paste the 
cita� on.

7.  Be sure to clear the Cita� on Viewer window before 
crea� ng your next cita� on.

8.  Click on the View link to see the en� re reference 
and to access the Edit command if you want to make 
changes.

One Line/Cite View Bibliography

1.  Save the document you have just created before 
forma�  ng the paper and the bibliography.

2.  Click on the Bibliography bu� on from the Cita� on 
Viewer window or from within the RefWorks 
program.

3.  Select the Output Style you need and use the Format 
Paper and Bibliography op� on to browse for the 
document.

4.  Click on Create Bibliography.
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FOOTNOTES:  For all op� ons, use the word processor’s footnote 
forma�  ng feature, inser� ng references using the “Write-N-Cite 
Paper” or “One Line/Cite View Paper” steps described above.

Quick Search
Use the Quick Search feature as a search of all fi elds.  To 
produce maximum results, all search terms entered are 
connected by the Boolean connector OR.  In addi� on, 
searches retrieve embedded terms - a search for “art” 
retrieves references with “heart,” “part,” etc.  The results 
of a Quick Search are always ranked by relevancy.

1.  Enter search terms in the Search RefWorks box.
2.  Click on GO.
3.  Results are displayed with the search terms highlighted. 
 

Advanced Search

Finding References in 
Your RefWorks Database

There are three ways to search your RefWorks 
database:  Quick Search, Advanced Search and Look 

Up Indexes.

Advanced Search makes it easy to perform fi eld-specifi c 
searches (e.g., Author, Title, Keyword), construct Boolean 
queries (i.e., AND, OR, NOT), and limit the search to a 
specifi c folder(s).  The results of an Advanced Search are 
displayed alphabe� cally by author, with the search terms 
highlighted.

1.  Click on the Search drop-down menu and select 
Advanced.

2.  Enter search terms and corresponding fi elds into the 
Advanced Search menu.

3.  Connect the terms by using the Boolean operators.
4.  Select All References or specifi c folders to search.
5.  Click on Search.
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Need More Help?

Online Tutorial

A tutorial providing explana� ons of various RefWorks 
func� ons is available online, along with an Advanced 
User Tutorial.  Use the Help pull-down menu to access 
the tutorial.

Support

E-Mail
Send ques� ons or problems to reference@laurentian.ca
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